Using Outpost Manual

OUTPOST - описание (с картинками)

Я уже имел счастье сделать мануал одного в своё время весьма популярного среди меня и многих других пользователей файервола под названием ATGuard. Сейчас я его не использую по ряду причин, о которых вы можете почитать в том мануале, однако должен сказать, что по непроверенным мною сведениям, проект ATGuard был куплен какой-то фирмой и доведён до ума, и вроде свежая версия уже не имеет тех жутковатых багов, о которых я высказался. Впрочем, я не собираюсь испытывать новую версию, а здесь и вовсе об этой программе речь вести не собираюсь. Однако, рекомендую тот мой труд изучить, чтобы, во-первых, он не пропал даром :), а во-вторых, там могут оказаться дельные мысли. В частности, я не собираюсь повторяться насчёт элементарных мер безопасности и прочей полезной и просто обязательной для уважающего себя юзверя инфы. Здесь я дам только довольно сухое описание Outpost'a, проиллюстрировав его, как водится, скриншотами. Описывать я буду версию Pro - она, в отличие от бесплатной, работает в XP, и это существенно. Бесплатная версия в ХРе глючит безбожно. Кроме того, я предпочитаю ставить английские версии программ, даже если есть русский интерфейс, поэтому пожалуйста, если у вас установлена русская версия, увязывайте её с тем, что увидите, самостоятельно. ;)

Начнём знакомство - на первом скриншоте вы видите простой и незамутнённый хитромудростями на манер Zone Alarm'a интерфейс.

Слева вверху показаны открытые соединения, чуть ниже следуют иконочки просмотра логов разрешённых (Allowed) и заблокированных (Blocked) соединений. В правом окошке как раз и можно наблюдать сей лог. Потыкавшись в него правой кнопкой мыши, можно настроить его как душе угодно, выбрать нужные поля, отфильтровать данные по любому полю или по времени (всё, текущая сессия, сегодняшний день), ну и много ещё чего. В нижней части левого окошка находятся плагины. Про них я ещё расскажу подробно, но пока вам будет, наверное, интересно узнать, что если вы разбираетесь в программировании, вы можете наделать плагинов под свои личные нужды, если вас не устраивают готовые или вам надо реализовать что-то специфичное.
Быстро попасть в конфигурацию каждого плагина можно, кликнув на нём правой кнопкой (чтобы получить контекстное меню). В общем, почитав хелп и полазив по этому экрану, вы легко разберётесь с интерфейсом сами, хотя там есть много вещей, достойных подробного описания. Обратите внимание, в меню Файл (я специально вытащил его на фотографию, пожертвовав внешним видом) вы можете сохранять разные конфигурации настройки Outpost'а, что может оказаться очень удобным. Например, сделали одну конфигурацию для сына (с запретом всяких порнушных сайтов), а другую для себя (с разрешением оных), разве ж не удобно? ;)

Ну что же, идём дальше, в меню Опции. Здесь вы можете выбрать, идти ли в общие настройки, в настройки приложений, системные или в полисы. Это разнесено для дополнительного удобства; на самом же деле все опции находятся на одном окне, но только на разных закладках. Пожалуйста, обратите внимание на изменившееся содержимое правой половины окна. Там теперь виден лог "атак". Мы ещё вернёмся к этому скриншоту, когда я буду рассказывать об этом плагине.

Начнём с General.

Эти опции просто настраивают некоторые бытовые мелочи, как то: ведение логов (максимальный размер и ограничение по времени хранения), автоматический старт вместе с системой, минимизация в трей (в том числе и по закрытию окна), а также установку пароля. Всё это просто и объяснений не требует. Однако тут есть опция, которая у меня не отмечена - Apply rules without need of interface. Про неё, в общем-то, как и про всё, можно почитать в хелпе, но я попробую рассказать это простым языком. Во-первых, переводится это как "Применять правила без вызова интерфейса", то есть втихомолку. Создатели для использования этой опции рекомендуют убрать галочку с показа иконки в трее и включить автозапуск вместе с системой. Теперь файервол будет работать как сервис, без интерфейса, так что вы можете быть спокойны, что сынок не полезет без спроса играть в игрушки в интернете. Также это может быть полезно для сбережения системных ресурсов на слабых машинах, хотя справедливости ради надо сказать, что даже Zone Alarm'у далеко до Outpost'а по части экономного потребления ресурсов, не говоря уже о прожорливом Нортон Интернет Секьюрити. Естественно, прежде чем переходить в безинтерфейсный режим, необходимо настроить программу как следует. Что ж, давайте этим и займёмся.
Самый простой способ сделать это - запустить программу в режиме обучения (Rules Wizard - в трее иконка выглядит как знак вопроса на фоне синего кружочка), и она сама спросит вас, что делать, когда какая-нибудь прога полезет в интернет. Выглядеть такая попытка выхода будет примерно следующим образом:

Как видите, для некоторых программ даже имеются готовые пресеты (например, Browser пригодится для IE; для почты, аськи, ирки и много чего ещё тоже есть пресеты), однако сейчас не тот случай, чтобы давать излишнюю волю Интранет Чату. Выберем Other:

Вот оно, окно создания правил. Пробежимся, надо научиться ориентироваться в нём хорошо. В верхнем окошке отмечаем галочки условий. Ими задаётся возможность настроить протокол (TCP или UDP), направление (Inbound, Outbound), хосты, а также порты локальные или удалённые. Всю эту кухню я подробно расписал в мануале ATGuard'a, так что если что-то непонятно, идите просвещаться туда. Во втором окошке задаётся действие Outpost'а по отношению к этим условиям. Вы можете разрешить, запретить, отклонить и дополнительно потребовать извещения о возникновении прецедента. Если вы поставите галочку на Allow, то две следующие будут недоступными, что вполне логично. Кстати, разница между Deny и Reject следующая: вторая опция сообщит компьютеру, делающему запрос, что его обломили, первая же оставит его в неведении. Очень рекомендую отмечать именно её. Кул хацкеры на то и кул хацкеры, чтобы догадываться о причинах потери пакетов самостоятельно. Помогать им в этом не стоит.
Что же дальше? В третьем окне мы как раз и задаём отмеченные ранее протоколы и т.д. Чем больше галочек стоит в первом, тем больше строчек будет здесь, тем более узконаправленным будет правило. Ну и в четвёртом окне вы можете дать название правилу, чтобы не путать его с другими, потому что их можно легко включать и отключать такими же галочками в окне правил. Но об этом потом. Пока же посмотрим, как можно изменять параметры настройки. Ткнём, к примеру, в хост zu.link-ul.ru:

Хост уже был получен нами при попытке коннекта чата. Здесь же мы можем добавить имена или IP-адреса других серверов, к которым планируем коннектиться. Довольно странно себя ведёт IP range - постоянно ему не нравится тот диапазон, который вам хочется задать. Например, при попытке задать диапазон, скажем, от 1.1.1.1 до 195.151.40.1 он скажет, что такого диапазона в природе нет, предложит подогнать под ближайший допустимый, и выдаст такое, что просто хоть стой, хоть падай. Каким методом он пользуется при вычислении допустимых адресов, для меня загадка. Ну да ладно, такие суровые меры как обрубание всего интернета, нужны очень редко. Мне за всё время работы с Outpost'ом (почти полгода) приходилось отшибать непрошенных гостей всего несколько раз. Для сравнения, ATGuard же просто задалбывает выпрыгивающими окошками.

Подобным образом можно настроить и порты. Можно перечислить их через запятую, указать диапазон, а также выбрать по имени сервиса, список некоторых вы видите наверху, либо просто написав имя сервиса ручками. Итак, закончив все телодвижения, мы попадаем на экран правил.

Как видите, всё предельно ясно и просто. Ткнувшись на правило, в нижнем окошке мы можем лицезреть его содержание и даже редактировать параметры, не заходя в Modify. Галочка на правиле позволяет мгновенно включить его или выключить (естественно, надо не забыть применить изменение). Кнопка Copy позволяет сделать ещё один дубликат выбранного правила, чтобы подредактировать его, не меняя исходник. Также можно вызвать готовый пресет (Preset), а потом поковырять его, удалив лишние или добавив свои правила.

Итак, нажав ОК ещё раз, мы применили правило, и теперь наш ICHAT появился на второй вкладке опций, посвящённой приложениям. Здесь тоже особых премудростей нет. Можно добавить какую-нибудь программу самостоятельно, не дожидаясь, когда она полезет в интернет (кнопка Add). Для редактирования проги не обязательно выделять её и нажимать кнопку Edit - достаточно просто дабл-кликнуть её. Можно также одним движением мыши отправить программу в немилость (Blocked applications) или же дать ей полную свободу шарить по интернету (Trusted applications). Первое иногда требуется, второе я бы рекомендовать не стал. В любой момент программу можно таким же макаром вернуть под контроль в средний список. Переходим на вкладку системных настроек.

Галочка про NetBios нужна, если вы юзаете сеть. Иначе ни один компьютер не увидит ваши расшары, а вы не увидите сетевое окружение. Кроме того, уже упомянутый IChat, если не подключён к серверу, а юзается по мэйл-слотам (как долгое время было в нашей сети), тоже без нетбиоса никого не увидит. Зайдя в Settings справа (самую верхнюю кнопку из трёх), вы можете добавить адреса, дозволенные для коммуникаций этого рода. Хочу сразу сказать, что если вам понадобится отключить какую-то персону, то это будет сопряжено с изрядным геморроем. Придётся разрешить все нужные адреса, кроме него. В сочетании с проблемой нормального задания диапазона, о которой я уже говорил, это приводит к тому, что вы просто плюёте на эту персону либо сносите Outpost и ставите ЗонАларм. Впрочем, не так уж всё и плохо в этом плане. Наверное, я просто преувеличил. На самом деле настроить выборочное отключение нужных (точнее, ненужных) адресов реализовать можно. Но всё же над этим авторам не помешает поработать.
В двух словах расскажу про Answer Type. Точнее, просто переведу, что написано, а там уже сами решайте, что поставить. 1) Скрытый. Не извещать источник при получении сообщения ICMP. 2) Нормальный. Отсылается обычный ответ "порт закрыт", если получено такое сообщение. Итак, предвижу главный ваш вопрос, что такое ICMP. Расшифровывается это как Internet Control Message Protocol. Если же сказать по-рабоче-крестьянски, то это пинги. Кул хацкер вас пингует и получает ответ: порт закрыт. "Ясно," - думает кул хацкер и идёт проверять следующий порт. Когда все они заканчиваются, он идёт проверять другой компьютер. Но представим другую ситуацию. Кул хацкер не получает ответа на пинг. "Наверное, нет тут никого," - думает кул хацкер и идёт проверять другой компьютер сразу же. Ну, какой вариант вам больше нравится? Наверное, с честным ответом. Ваш комп хорошо защищён, и чтобы хацкеру в него влезть, сильно постараться придётся. А до ближнего вашего, ламера начинающего, может, и не доберётся - устанет. А если вы и есть такой вот, кхм-кхм, начинающий, то поставьте стелс, чтобы он шёл мимо, к продвинутым пользователям. ;)

В это окошко мы попадаем, нажав на среднюю кнопку Settinds. Рассказать подробно о происходящем здесь я, к сожалению, не могу. Если вы продвинутый пользователь и знаете, что к чему, то разберётесь и самостоятельно. А если вы такой же ламер как я, то либо отметьте то же, что и я, либо вообще оставьте настройки по умолчанию. Скажу только, что пользователям нашей локальной сети необходимо иметь галочки там, где вы видите их на скриншоте, потому что, например, две служебные машины пингуют сеть, в результате чего админам известно, какие компы включены и у них точно есть интернет, и какие выключены либо имеют проблемы с коннектом (хаб умер, неправильно настроен фаерволл или ещё что-то случилось). Если же вы не отметите Echo Reply и Echo Request в оба направления, их пинги не получат ответа, и они будут думать, что ваш компьютер выключен, и очень удивятся, когда увидят, что с вашего адреса кто-то лезет в интернет (хотя этот кто-то и будет вами). Конечно, включив эти галочки, вы дадите себя обнаружить и кул хацкерам, но не бойтесь, я расскажу чуть ниже, как их можно обломить.

Вот они, глобальные системные настройки (нижняя кнопка Settinds). Здесь вы можете позакрывать все подозрительные порты, запретить "левые" адреса (но не те, которые уже разрешены в установках нетбиоса) и вообще глобально порулить. Здесь уже есть куча готовых правил, которые не вредно бы почитать для ознакомления, а также при необходимости подкорректировать. Не рекомендую корректировать их в сторону дозволения. Например, не отменяйте блокирование вызова удалённых процедур, ибо нефиг - свои процедуры пускай вызывают. :) Но я не шучу, хоть и улыбаюсь. Те, кто знает, что делает, должны знать, что предпринять во избежание неприятностей, а мы же скромно примем с поклоном приготовленные правила как они есть. Как видим, правила можно копировать, редактировать, удалять, создавать новые. Кроме этого, тут появились кнопки Move Up и Move Down. Они нужны вот для чего: в этом окошке действуют приоритеты, то есть, правила, расположенные в самом верху, имеют большую силу, чем нижележащие. Например, если вы поставите наверх правило, запрещающее всё на свете, то проку от вашего фаервола будет немного. Баланс - вот rulez! Кстати, обратите внимание, при создании глобальных правил набор протоколов расширился.

Выбрав протокол IP, можно задать его тип, коих имеется целый вагон.

Таким образом, можно задать уймищу разных правил, определяющих взаимоотношения вашего компьютера с сетью и интернетом. Например, можно решить задачу по пингам. Зададим глобальное правило, разрешающее пинговать нас только с zu.link-ul.ru (195.151.44.129) и с gw.link-ul.ru (195.151.42.6), чуть ниже - правило, запрещающее ICMP на все адреса, и всё - кул хацкеры в пролёте. Теперь они думают, что наш компьютер выключен, но мы просто спрятались в засаде, и пока они не очухались, переходим к полисам.

Сейчас у нас установлен режим самообучения. При попытке контакта, который программе ещё незнаком, она задаёт нам вопрос, блокируя при этом программу. Иногда, однако, бывает удобно на некоторое время переключиться в режим Allow most, девиз которого - "всё, что не запрещено - разрешено". Например, при пересылке файлов по DCC в mIRC что-то заедает в этом фаерволле, и мне, честно говоря, лень копать. Поэтому я просто кликаю правой кнопкой мыши на иконку в трее, выбираю Policy, и там - нужный режим. Затем всё так же легко возвращается назад. Далее, режим Block most. Его девиз имеет противоположный смысл - "всё, что не разрешено явным образом, долой". Этот режим помогает, если вы уже заготовили правила для всех нужных вам программ и теперь не хотите, чтобы вам надоедали выпрыгивающие окна (впрочем, они и так нечасто досаждают - правила создаются достаточно глобально, так что, разрешив один раз The Bat принять почту с помощью готового пресета, вы избавляете себя от головной боли по созданию правил для каждого ящика). Stop all mode просто блокирует все коммуникации. Это бывает необходимо, когда надо срочно "выдернуть сетевой шнур". И наконец, последний режим отключает файерволл и позволяет всем и вся безнаказанно лазить по вашему компу. Полезен этот режим в том случае, когда настраиваете какую-нибудь прогу, которая никак не хочет выходить в интернет или сеть - вы отключаете фаерволл и смотрите, заработала она или нет. Если нет, то дело в программе, если да - в фаерволле. Внизу этого экрана вы видите Trusted Zone - туда вы можете внести компьютеры, которым безоговорочно доверяете. Например, у вас есть дома второй компьютер (жены или детей), который составляет с вашим маленькую сеть. Ну или на работе глупо прятаться от коллег, которым могут быть нужны какие-то данные на вашей тачке. Вот их добавляйте в зону доверия, и коммуникации с ними будут позволены всегда.
Переходим к плагинам.

Одно из главных достоинств Outpost'а - подключаемые модули (plug-ins). Те, что вы видите, разработаны компанией Agnitum, и они успешно справляются с возложенной на них задачей. Однако, радует, что авторы дали людям возможность проявить себя в совершенствовании программы. Как я уже сказал, при желании вы можете написать свой собственный модуль. Пока же рассмотрим имеющиеся. Модуль Ads позволяет вам легко и просто резать баннеры со страниц в интернете, экономя трафик и сокращая время загрузки. Уже готовы кучи строчек, по которым Outpost отсекает содержимое. Кроме этого, можно задать часто встречающиеся размеры баннеров, правда, в этом случае иногда он будет блокировать "хорошие" thumbnails, которые просто совпали размером с запрещёнными.

Следующий плагин - Content - блокирует целые страницы, в которых встречаются заданные вами слова. Страница загрузится, но вместо содержимого будет стоять надпись огромными буквами, извещающая о том, что содержимое блокировано Outpost'ом. Можно указать непосредственно адреса сайтов, которые надо блокировать - это вы можете сделать на соседней закладке.

Полезен модуль DNS Cache. Он хранит последние 100 записей DNS-адресов и их IP-эквивалентов. Браузеру было бы удобнее, если бы мы писали адреса цифрами, но у нас мозги лучше работают с буквами, поэтому мы пишем адреса в виде www.vasya.ru, а браузер обращается к DNS-серверу для перевода этого адреса в удобоваримый для него цифровой вариант. Кэш помогает ему и вам - меньше трафик, быстрее загрузка страниц.

Модуль Active Content расправляется с "куками", Active X, редиректами, выпрыгивающими окнами и прочими наглыми выходками некоторых веб-страниц. Я подробно описал эти вещи в мануале ATGuard'a, поэтому здесь ничем больше не обмолвлюсь по этому поводу. Разве что посоветую поставить везде, где возможно, Prompt - предупреждать.

В этом случае файерволл будет предупреждать вас о наличии активного контента и спрашивать, что с ним делать - блокировать ли насовсем, насовсем ли разрешить (Block All, Allow All) или же по нажатию ОК сделать одну из двух этих операций лишь для данного сайта - как на следующем скриншоте.

Далее идёт фильтр аттачмента почты. Особых проблем он вызвать не должен, так что ограничусь лишь демонстрацией этого экрана.

Ну, и последним номером в нашей программе идёт очень интересный модуль. Он детектит атаки на ваш компьютер и предпринимает некоторые действия, если происходит что-либо серьёзное.

Итак, наверху мы видим ползунок, которым регулируется степень параноидальности фаерволла. Наверное, лучше поставить его в положение Normal, в котором предупреждение идёт, если зарегистрировано сканирование нескольких портов. Шизнутый режим, когда каждое сканирование будет писаться в лог, пожалуй, не нужен, равно как и слишком успокоенный - оповещение идёт только в случае явной атаки.
Чуть ниже вы можете указать действия, которые надлежит выполнить фаерволлу, если зарегистрирована атака. Блокировать весь трафик не рекомендуется, так как это будет больше мешать вам, чем злоумышленникам, хотя иногда может и пригодиться. Лучше всего заблокировать адрес кул хацкера на часок, и можно до кучи и всю его подсеть тоже (третья галочка). Правда, если хацкер был из вашей собственной сети, то вы этой третьей галочкой больше навредите опять-таки себе. Ну и обязательно надо отметить галочку про DOS-атаку. Помните, я обещал вернуться к одному из первых скриншотов, когда речь зайдёт об атаках? Ну так вот, там вы можете увидеть, с каких адресов "просвечивались" ваши порты, и какие именно, а также время сканов. Это очень полезно для анализа. Например, при перекачке фильма по сети лог будет забит сообщениями о сканировании ваших портов с той машины, которая качает у вас файл (или с которой качаете вы). "Своих" можно проглядывать вполглаза. Но если такая тенденция просматривалась по отношению к незнакомому айпи, то нелишним будет как минимум просмотреть лог на предмет других сканов с этой машины. Иногда в этом логе будет появляться надпись, например Moyari13. Так называется один из видов атак, когда сканируются определённые порты. Мы в сети проверяли это дело, сканируя друг друга, - жертв и разрушений нет. :) Но также почему-то не блокировался адрес атакующего. Может быть, для блокирования простого сканирования маловато? DOS-атаку мы не пробовали, поэтому про неё сказать ничего не могу. Подробнее о детектировании атак и сканов читайте хелп - там достаточно просто и ясно всё рассказано.

Напоследок расскажу немного об одном файле, который используется Outpost'ом при обнаружении атак, а также при борьбе с ними. Называется он protect.lst, а лежит в рабочем каталоге программы. Почитав его, вы гораздо яснее станете представлять себе, что такое компьютерная безопасность и какими средствами она достигается здесь. То же самое сделал и я, немного вник в суть дела и понял, что этот файл можно существенно дополнить. Дело в том, что там уже заданы кое-какие порты, которые могут быть предположительно атакованы троянами. Если вы читали мануал ATGuard'a, то наверное, помните, что этих портов на самом деле много. И вот, я не поленился и вбил (точнее, вклеил) весь этот список сюда, в этот файл. Ещё я обнаружил там некоторую дырку. В самом конце файла можно указать адреса машин, которые не будут проверяться на предмет атак (этакая Trusted Zone). По умолчанию в файле прописано несколько машин, по всей видимости, это адреса фирмы-производителя. Конечно, я доверяю авторам фаерволла, но адреса "поремал" (поставил в комментарии, чтобы они исключились из-под действия этого правила). IP-то можно и подменить, в конце концов. В общем, так, файлец этот я выложил здесь, можете его посмотреть, нажав ссылку левой кнопкой, и скачать, нажав её правой и выбрав "Сохранить объект как...", чтобы использовать у себя.

И ещё пару слов о недостатках программы. Они есть, и их надо как-то бы исправить (это я авторам намекаю, если они прочтут невзначай мою статью). Самый крупный - это неудобная работа с логами. Почему-то они не сохраняются автоматически в виде файлов, и если вдруг компьютер повис или вы просто не прочитали или не сохранили логи перед перезагрузкой, то потом просто их уже не увидите. Может быть, как-то это и включается, но в таком случае это запрятано весьма глубоко, что было бы довольно странным при таком простом интерфейсе (который, надо сказать, мне нравится). Второй (уже упоминавшийся мной) недостаток - "странности" в задании диапазонов. Хотя может быть, так и должно быть? В таком случае хотелось бы почитать про это в хелпе, достаточно хорошо, кстати, написанном. Ну и третий камушек в его огород - тоже уже упомянутая невозможность блокировать один айпи из разрешённой в нетбиосе сетки. Я пробовал создавать глобальные правила, запрещающие доступ с некоторых адресов локальной сети, по протоколам TCP и UDP на портах NetBios, и всё равно они спокойно заходили на мои ресурсы. (Не подумайте, ради Бога, что на расшару может зайти кто попало. Те адреса, которые не разрешены в настройках NetBios'a, даже не узнают, что у вас открыт 139 порт. Я проверял надёжность блокирования своих портов, используя специальные интернет-сервисы, например, ShieldsUp - результат выше всяких похвал: ни одной дыры! Кроме того, тестировал Outpost на прорыв изнутри, с помощью программки LeakTest от автора ShieldsUp - тоже держит.)
Но в целом достоинства программы - простой и ясный интерфейс, подробные логи (где, кстати, даже трафик каждого соединения можно увидеть), надёжная защита, неприхотливость в смысле ресурсов, а также модульность - перевешивают эти мелкие неудобства. К тому же не надо забывать, что Outpost ещё молод (версия Pro - это второй релиз версии 1), и ему есть куда развиваться.

Подумав, я решил всё же скопировать сюда из того мануала
Общие правила и рекомендации по работе с фаерами (не только этим):
- Ставьте файервол самым первым из всех программ (если вы юзаете инет по модему, это, конечно, не очень актуально). Но тут у нас СЕТЬ, т.е. пока сетевой кабель воткнут (и сеть настроена правильно, конечно же), компьютер считается подключённым к интернету. Со всеми вытекающими отсюда последствиями.
- При переустановке системы выдерните сетевой кабель. Поставив и настроив её, ставьте файервол, перегружайтесь, и только после того как он настроен, включайтесь в сеть. (Почти дублирование предыдущего замечания.)
- Если для чего-то вам понадобилось его отключить, НЕ ЗАБУДЬТЕ потом включить обратно.
- Ведите логи и регулярно их почитывайте. Узнаете много интересного. Вообще возьмите за правило смотреть логи за тот период, когда вы отлучались.
- Лучше лишний раз запретить. Правда, можно случайно запретить какую-нибудь системную службу, из-за чего вы не сможете, допустим, выйти в чат. Но всё это можно наладить и потом. А вот если вы впустите к себе трояна, выковырять (и даже просто обнаружить его) будет намного сложнее.
- Правда, перебарщивать тоже не стоит. Если не отдаёте себе отчёта в том, что делаете, лучше не делайте.
- В общем, разбирайтесь в проге, хоть методом научного тыка, хоть чтением хелпа. Это относится не только к фаерволам, а вообще ко всем программам, да и вообще ко всему, что вас окружает. Спокойно! Я не учу вас жить. Хотя... учу... :)))

Ну вот и всё. Убил ли я напрасно несколько вечеров, ковыряясь с сим документом, или он кому-то поможет, покажет время. Пока же благодарю за внимание и прошу все дополнения, порицания, благодарности и сообщения об отловленных ошибках как-нибудь сообщать, например, на мыло talking_zero@mail.ru или в чат.

(c) Усы, Oct 2002

Если Вы попали на эту страницу через поисковик, то скорее всего, видите только её, в то время как она является одним из фреймов, либо вообще относится к одному из дополнительных проектов. Для того, чтобы попасть на главную страницу сайта, нажмите сюда - она откроется в новом окне.